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Comes v. Microsoft

To: Tom Lemberg

cc:

From:- Sald Mohammadioun
Date: 09/17/91 03:58:39 PM
Subject: Microsofts new style guide

Tom, this Is some stulf for your files.

Richard,

Are they asking for comment? We should be very vocal about our objections not so much on Rts bias
toward MS apps, but on the grounds that MS does not need to dictate all these details. Most of these

should be left o developers choosa and for the customers to decide what the standard should be: voting
with their §'s.

To: Don Casey

cc: Alex Morrow, Frank King, AFESC, AI-PSC, Al-TSC, Richard Wolf
From: Richard Wolf

Data: 09%/11/91 07:03:09 PM

Subject:

This memo lists and briefly describes items in the draft Microsoft Style Guide for Windows that are
biased toward Microsoft applications. Individually, none of the items are major changes. They are a
collection of small arbitrary decisions without clear user benefit that taken together give Microsoft an
advantage because most of their applications already conform.In the few cases where aspects of the style
gnﬂehawnmalmadybemmphmmmdby&mamtapp&ﬂmmabkbmthﬂths
bebavior is implemented in forthcoming versions. -

There are two issues about the document itself, The document is not structured as a normal style guide
with levels of conformance clearly spelled out. The document does not clearly distinguish between
requirements and recommendations, so it is difficult to determine what is mezely a suggestion and what is
a required aspect of the user interface. This would make it difficult for ISVs and customers to clearly
gage conformance, which would be especially troublesoms to the extent that the style guide becomes a
procurement document. The document is not arganized as a refereace manual so it is difficul to use,

Second, the style guide provides little oc no indication of future object oricated vser interface directions
that Microsoft is developing, including property sheets, direct manipulation, pop-up menus, and notebook
techniques. Essentially, current and somewhat arbitrary GUI practices of Microsoft applicatons are being
set up as detailed standards while Microsoft works on new approaches that obsolete these standards,
Microsoft has privately disclosed to Lotns some elements of their intended direction.

I have copies of the document for anyone who wants to review it in more detail.

The st is organized in two pats, ficstitems pertaining 10 bebavicr, then iterns pestaining to appearance.
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lcon palette
The style guide essentially describes the tool bar from Excel and Word and uses pictures from
Word (although MS claims they want to find more neutral pictures). Configurability is not
discussed - it is not prohibited, but considering its importance to users and many vendors, not
only Lotus but also WordPerfect, it is not even mentioned. Icon palettes are by design cither
fixed or moveable, and implicit in the design is tbe assumption that this is not 2 user
configurable setting (like in Lotus apps). Control over the appearance of the icon palette is
placed on the View meau Gf the paletto is fixed) or the Window menu (if the palette is
moveable), which is unworkable given user configurable icon palettes and inconsistent with
Lotus applications, Moveable icon paleties are required to have a miniatore title bar to allow the
nser a convenient means to reposition the palette, which is a good idea, but there is no system
support provided to help implement it (pote: most MS apps bave fixed icon palettes, so it is not
yet am issoe for them). Finally, buttons on an icon palette are required to show the state of the
selection, ¢.g., 8 Bold button should appear depressed when bold text is selected. This is a good
idea, but not done in Lotus apps because of perfarmance concerns.

Selection of text blocks In graphics
The document requires text blocks in a graphics region to be sclected in a mamner employed
only by Excel and Power Point and not in any other major spreadsheet or drawing application
{c.g., Houdini, Freelance far Windows, Micrografx products, or Aldus Persuasion). According to
the style guide the first click on a text block selects the block as a whole and the second click
(note: not a double click) selects text within the text block and positions the insertion point.
Most other apps use an explicit mode that is entered by choosing a text tool from a too] palette
or amouse doublke click (like Houdini).

File Open Mail and File Send Malil
The document requires access to mail to be placed on the File menu in the form of two
commands, Open Mail and Send Mail, which reflects the MS mail product on the Mac and their
pmbableinmndonsforW‘mdow:.noucoweusnsongooddmgn.

Text search and substitution
Thclcxtscmchandsubsamnonmmandisspﬁthtotwoseparaecommandsanddialogboxcs.
called Find and Replace, like Excel and Word, rather than one command and dialog box called
Find, like Rockport, Houdini and some other apps, There is no clear user benefit for requiring
two commands. Note, however, that other apps such as WordPerfect split this command into two
commmds.AkonowthuWordmlhmeucommmdsSmchdecphce,soMSmdm
lha:mnppshavclochmgcuwdl.

Spelling checker
A standardized spelling checker is proposed which looks fike the Word spelling checker.
Although it may eventoally be appropriate to standardize this facility, baving MicrosoRt do it
Dow secms arbitrary rather than necessary since spell checking is still considered &
differentiating feature of an application,

File Opon

This is a new dialog box for Win 3.1. No app has shipped it yet, although Visual Basic includes
the new style ofﬁnbomcmuohthatmneededtobnﬂdthndulog.

File Save As
This is another new dialog box for Win 3.1. It bas some problems involved with greying out the
Iist box choices 50 its design is questionable, No one has shipped it.

Borders

Another new standard dialog. It's design is questionable and in any cvent this should be
. considered the domain of the application, not a system standard, While all apps would bave to
change their current implementation, MS apps probably have a bead start, m
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Character properties (Font)

Anotber new standardized dialog that requires some changes for everyone, There are some
design issues with respect to ATM vs. TrueType in this dialog box. Rockport would bave to
change more than most, due to its slotted font model.

Print dialog
This is a new dialog standard, It Jooks like Word's prm( dialog. Excel, Lotus apps, and most
otber apps would require changes.

Window menu
The style guide reccommends one Arrange All commmand that tiles the windows over separaie Tile
and Cascade commands (which are secondarily recommended) even though CUA 2.0, the
Windows Program Manager and the Windows File Manager use Tile and Cascade. Excel and
Word use Arrange All.

Samples In dlalogs
Samples (WYSBYGI) of impending changes in dialog boxes are recommended and are already
in Bxcel. They are also included in AmiPro but not in Word.

Macro record
The standard commands on the macro menu include Record, which assumes that the user must
explicitly turn on the recorder, uvnlike the 1-2-3 design.

Multiple instance
Multiple instances of an application are generally recommended and additional files opened
from the file manager are to be opened in another instance of the associated application. Excel
supposts multiple instances, as does AmiPro. Word, Rockport, and Freelance for Windows do
not, ’

MRU List
A Hst of the most recently used ﬁles should displayed at the bottom of the File menu, This is a
300d idea that is atready in Excel, Word, and AmiPro, but is t00 detailed and arbitrary for
nclusion in a standard.

Repeat (last action)

_ Rt is reccommended that apps inclede a Repeat (last action ) command in the Edit menu. Excel
" and Word already do this,

Double clicking spilt box
Double clicking the split box should split the active window in the middle or remove a split if
the window Is already split. Word does this but not Excel (yet).

Resizing multiple draw objects
When the user selects multiple draw ob,;as.allob;eax are to be resized proportionately and not
to change relative position, Execlworhhkethn.bmkod:pmndme other Windows apps
do not. Note that Hovdini does work fike this.

CTRL key to lock down a drawing tool
Holding the CTRL key while selecting a drawing tool locks down that toal so it repeats (pmsthe
system in 2 mode). Excel and Powerpoint already do this and Lotus apps do not.

Radio button double click
Dm»bbclmhngonaradxobwonhmmmdedummhmmdow a dialog box. Excel
and Word already do this, but Rockpost doesviot: ™ =~~~ "~

Drag spiit bar
It is recommended that the user can drag the split bar (as well a3 the split box) to-adjust a split.
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Status bar display

Control over the presence or absence of the status bar is to be on the View menu, if the app has a
View menu. Word does this and Excel does not bave a View meaun.

Appearance

Push button arrangement In dialog boxes ’
Two styles of push bunon arrangemeants in dialogs are allowcd. push buttons in the upper right
(like Excel, Word, and many other Windows apps) or push buttons along the bomom (like the
Windows Program Manager, File Manager, and the system sopplicd applettes). Rockport style
push buttons in the lower right, which are also employed by WordPerfect and some other
‘Windows apps, would not be allowed.

‘This is a good example of a caso where two inconsistent approaches are arbitrarily incorporated
into the spec simply because Microsoft bas not been able to arrive at internal agreement, yeta
third approach is discarded because Microsoft has no stake in that approach.

Macro pull-down menu
Apps that support macro writing and/or recording are to have a Macro pull-down on the menu
bar. Excel and Word already do this, but Rockpart does not. This may be a problem for many
apps that can not give up the menu bar space. Some vendors, inclndingWordPerfect. do bave a
scparate macro pull-down.

Cascading menus
The style guide recommends that madmg meous should be avoided whenever possible,
Rockport, Notes, Houdini, and many other vendors apps have a few. Woed and Excel have
DaDE. :

Unfolding dialog boxes
Dialogs with an Options>> botton that expands the dialog to reveal additional commands arc
the recommended but not required method for dealing with progressive disclosure, This
technique is used in Word and Excel.

Muttiple selection lists ’
The style guide specifies a pew style of list box for multiple selection lists that places a check
bax grapbic preceding cach position in the list. Notes bas this functionality in its views but does .
not use a check box. Moreover, there is 5o system support for implementing these lists w/icheck
boxes and it is reportedly difficult to implement.

Split box appearance
The split box is the box that a user grabs with the mouse to split a window, The style guide
specifies \hat:tbokliketbeExcchndWordvmms,ablackmcmﬂc.mhuﬂmn the more
informative Rockport version,

Mode indicators in status bars In ali caps

Mode indicators in the status bar are arbitrarily required to appear in all caps, like Excel and
Wa&nﬁa&mhamm&bhmhedmeﬁhko&mmm

Dialog titles
The documecnt specifies that dialog titles should not include the path name of the command that
invoked the dialog, like we iniernally agreed to do for all our apps.

Saeloction highlight is not ussr configurable
mfeedbackmahgmmgforasebcﬁon is always black as in Microsoft apps, rather than user -
conﬁgmabk as in Rockport. 001962
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Waorkshoeet titles
should be called Frecze Panes and should be provided independeat of window splits. This
feature is not yet in Excel but would require 1-2-3 to change. :

Minimized windows represented as icons in MDI
In an MDI minimized document windows should be represented as icous. Rockport does this,
but Notes does not: Microsoft apps do not provide minimization of docurent windows (which is
allowable in the stylc guide) so they don't run into this issue.

Size box '
The size box, a little box at the lower right of a window, should not be used by an app because it
is reserved for some unspecified system use. Word is the only application I know that will have
to change.

Menu changes on shift key » ,
Apps should avoid changing memu items when the shift key is beld down. Excel does this and so
will require a minor chenge, but I don't think many users cven knew aboot it.

Printer Setup becomes Print Setup
An arbitrary minor wording change which bits everyone equally,
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